ピックアップ記事
Unity CocoaPodsを インストール済みのはずなのに、 エラーが発生する

CocoaPodsをインストール済みのはずなのに、インストールしてくださいとエラーが出る

Unityでビルドしようとした際に、CocoaPodsをインストールしてくださいとのエラーメッセージが表示されました。

Please ensure you have at least version 1.0.0. You can install CocoaPods with the Ruby gem package manager:

そのため、以下のようにしてインストールを行いましたが、インストール完了後もメッセージが消える様子がありません。

(バージョン指定していないとインストールが上手くいかなかったため、指定しています。)

sudo gem install -v1.8.4 cocoapods -n /usr/local

 

原因

pod --version

 

念の為、バージョン確認をすると以下のようなメッセージが表示されました。

 

$pod --version
Traceback (most recent call last):
 5: from /usr/local/bin/pod:23:in `<main>'
 4: from /usr/local/bin/pod:23:in `load'
 3: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.8.4/bin/pod:55:in `<top (required)>'
 2: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/command.rb:49:in `run'
 1: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/command.rb:130:in `verify_minimum_git_version!'
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/command.rb:118:in `git_version': Failed to extract git version from git --version ("xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun\n") (RuntimeError)

 

解決法

Xcodeを起動させ、上部メニューのPreferencesを開きます。

Preferencesが表示されたら、Locationsを選択し、Command Line Toolsを確認します。

ここが設定されていないことで、今回のエラーが発生しているようなので、Xcode 11.5を選択することで、podコマンドを使用できるようになります。

最後に念の為、実行できるか確認しましょう。

pod --version

 

おすすめの記事